AOSIS eLearning: PHP 8.0 and the Ramifications

AOSIS eLearning has seen there is a few ramifications to PHP 8.0.

PHP 8.0 is a major update of the PHP language. It contains many new features, optimizations and improvements in the type system functions, error handling, and consistency. This is not good news for anyone.

Why PHP 8.0 have ramifications for many owners of Moodle Sites

Any Moodle version below Moodle 3.11.8 is not supported on PHP 8.0. Owners of Moodle sites are faced with a dilemma, they are forced to upgrade their Moodle site to 3.11.8 or a later release or risk their site no longer working.

You may have just spent money and time to upgrade your Moodle site, just to hear that it is not PHP 8.0 compatible, you may not want to do an upgrade right now or in these tough economic times, there may not be funds available for such an upgrade.

If you do not wish to upgrade your Moodle site, AOSIS have hosting solutions which do not require a site to be compatible with PHP 8.0. Contact us to find out more about this.


We are a Certified Moodle Partner and can assist with demonstrations and to answer any questions you may have. Please contact us at elearning.support@aosis.co.za

Subscribe to our AOSIS eLearning Newsletter

Receive eLearning content development tips, Moodle tutorials, Moodle tested plugins and Moodle best practices each month. Subscribe here.

Leave a Reply

Your email address will not be published.